BATT MOBILE COMPLETE

IMG_0275 IMG_0276

Okay so we fired up our vehicles today but it didn’t start. Andrew was wondering why didn’t it start. And then he realised that we didn’t power the controller. My mistake (Samuel). I totally overlooked the manual. I forgot to connect the 5V wire and the Ground to the controller. OOPS.

IMG_0279

So yes we fixed it and the controller starts! Time for the really messy part. We didn’t really take photos of that because it was basically just trying all permutations of the UVW and ABC wires. Only one combinations allows it to turn forward.

So we fiddled around with it for a little and we managed to get the left motor spinning at a really good RPM. However, the right motor was just being retarded and it didn’t wanna spin as fast. We had to troubleshoot the problem.

We realised that the problem is due to the hall effect sensor. One of the wires wasn’t soldered properly.

***LONG TECHNICAL POST COMING UP*** (Skip if you hate nitty gritty)

IMG_0278

Picture of the hall sensor. Not really close up but I think we have a close up pic in our previous post.

Okay so there are actually 3 hall sensors. Brushless DC motors (BLDC in short) actually “fire” in sequence to keep increasing the torque on the motor. They have to be fired at the precise moment. If they are not fired precisely at the right moment, the “firing” can actually slow down the motor. Think of it as pushing a child on the swing. If you don’t push the child on the highest point of the swing, you’re never gonna get him to go higher.

So our motor was actually not spinning at fast. We thought it was due to the firing sequence. As such, we moved the hall sensor to the left/right to find the optimal. However, we could still not achieve the same RPM as the right motor. As such, we decided to test if the hall sensors were soldered properly. It was definitely not the UVW ABC problem as it was spinning forward.

True enough, it was the hall sensor soldering problem. We soldered the B sensor. Well it wasn’t actually working, so the motor was only firing twice instead of thrice, which doesn’t make it as fast. (Naturally of course)

***LONG POST ENDS***

After soldering it, it works!

 

IMG_0281

 

Samuel in the car.

Next post: VIDEO OF BATT MOBILE MOVING

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s